Tuesday, March 08, 2016

BH Fitness TS4 Treadmill – Running belt adjustment – General maintenance – Error codes E1 – E7 – Error code troubleshooting – Treadmill repair and service

Category: Treadmill Repair and Service 

Contents of this article 

  • Running belt tracking adjustment
  • running belt lubrication 
  • Error codes E1 and E7




BH Fitness TS4

Belt Adjusting
When the running belt shifts to one side or simply ‘skids over’ while running, run the machine at 3 mph for a few minutes to determine which side the belt is drifting towards, left or right as described below.
If the belt is drifting LEFT
# Turn the treadmill off and unplug from the wall
# Tighten the left hex head socket a ¼ turn
#  Loosen the right hex head socket a ¼ turn
# Run the belt at 3 mph again for a few minutes
# Repeat the steps above as needed
If the belt is drifting RIGHT
# Turn the treadmill off and unplug from the wall
# Tighten the right hex head socket a ¼ turn
# Loosen the left hex head socket a ¼ turn
# Run the belt at 3 mph again for a few minutes
# Repeat the steps above as needed

Belt Lubricating
It is recommended that the deck be lubricated regularly according to the frequency of usage.
WARNING!
Do not use cleaner under the running belt or on the electronics especially while power is on.
Use 8 mm torque wrench to loosen the hex head socket in the end caps. Remove excessive accumulations of dust, dirt, and other debris from the running deck. ONLY use a clean, soft cloth.

Gently pull up the side of the running belt. Dispense a thin layer of the lubricant on deck, and spread evenly.
DO NOT over lubricate (2 uses per bottle) and only use supplied liquid silicone. DO NOT use wax or other types of lubricant as they might deteriorate transmission components and degrade the treadmill’s performance
GeneralCleaning
Disinfect and wipe the console dry after each use  As the motor spins, it attracts and collects lint and debris under the motor cover which could cause damage to the electronics.
Unplug the power and remove the motor cover
Vacuum the motor driver board, the motor fan blade and the surrounding. Take care not to damage wires and harnesses
Error code and troubleshooting
E1
Loss of Feedback
POSSIBLE CAUSES
1.Speed Sensor disconnected
2.Speed Sensor Misaligned
3.Faulty Speed Sensor
4.Loose Display Connection
5.Faulty MCB (D2 LED on)
6.Faulty Drive Motor
SOLUTION
1,Check Speed Sensor Connection
2,Check Sensor position
3.Replace Speed Sensor
4.Check Display Cable Connection
5.Replace MCB
6.Replace Drive Motor
E7
Elevation Motor ,Display doesn’t light up
POSSIBLE CAUSES
1.Elv. Motor out of range
2.On/Off Switch
3.Fuse
4.Insufficient power source
SOLUTION
1.Calibrate Elev motor
2.Check if unit is turned on
3.Check fuses on MCB
4.Plug unit in a dedicated 120V, 20A outlet